// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$").unwrap();
let string = "connected full enabled enabled missing enabled no (guessed)
unknown none enabled enabled enabled disabled";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}