$re = '/\W(banana|lemon|mango|pinea|200|assigned|1)/mi';
$str = 'asdasd
a PINEAPPLE 200 20 great oaks great oaks blvd 22 11 1 2 apineapple varun nikhin
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);