const regex = /^\[[^\]]*\]\s+|\s+\[[^\]]*\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^\\]]*\\]\\s+|\\s+\\[[^\\]]*\\]', 'gm')
const str = `There is a [blue] cloud on top of that [big] elephant`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);