use strict;
my $str = 'There is a [blue] cloud on top of that [big] elephant';
my $regex = qr/^\[[^\]]*\]\s+|\s+\[[^\]]*\]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";