#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\s\"'](?:src|srcset)\s*=)\s*([\"'])(?!\s*\b(?:(?:bres|https?|ftp)://|(?:data|javascript):))(?:file://)?[\x00-\x1f\x7f]*\.*/?([^\">]+)\2"
Local $sString = "<img src="us.png" srcset="us.png 1x, us-2x.png 2x">" & @CRLF & _
"<img src="us.png" srcset="us-2x.png 2x">"
Local $sSubst = "$1$2bres://dictid/$3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)