using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a.*?href="".*?//.*?"">.*?</a>)|(<a href=""/.+/"">dwdqwdqwd</a>)";
string input = @"dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href=""/dwdw.php/"">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href=""//dwdw.php"">dwdqwdqwd</a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}