re = /(\|description =\s*)([^\n]+)(.*\[\[)([^\|]+\|)([^]]+)/
str = '=={{int:filedesc}}==
{{Information
|description = wikiwoordenboek audio
|date =
|source =
|author =
|permission =
|other_versions =
}}
[[Category:Dutch pronunciation|Example]]'
subst = '\\1\\5\\3\\4\\5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result