import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(THE\\s)?((7)|ESTATE OF\\s))?(.*?)(-?\\s?DECEASED)?((P\\.?R\\.? OF THE)?(?(3)|\\sESTATE OF))$";
final String string = "SMITH JOHN ESTATE OF\n"
+ "SMITH JOHN J ESTATE OF\n"
+ "SMITH JOHN JAMES ESTATE OF\n\n"
+ "SMITH, JOHN ESTATE OF\n"
+ "SMITH, JOHN J ESTATE OF\n"
+ "SMITH, JOHN JAMES ESTATE OF\n\n"
+ "ESTATE OF JOHN SMITH - DECEASED\n"
+ "ESTATE OF JOHN J SMITH - DECEASED\n"
+ "ESTATE OF JOHN JAMES SMITH - DECEASED\n\n"
+ "SMITH, JOHN DECEASED ESTATE OF\n"
+ "SMITH, JOHN J DECEASED ESTATE OF\n"
+ "SMITH, JOHN JAMES DECEASED ESTATE OF\n\n"
+ "THE ESTATE OF JOHN SMITH\n"
+ "THE ESTATE OF JOHN J. SMITH\n"
+ "THE ESTATE OF JOHN JAMES SMITH\n"
+ "THE ESTATE OF JOHN J. SMITH, JR.\n"
+ "THE ESTATE OF JOHN SMITH DECEASED\n"
+ "THE ESTATE OF JOHN J. SMITH DECEASED\n"
+ "THE ESTATE OF JOHN JAMES SMITH DECEASED\n"
+ "THE ESTATE OF JOHN J. SMITH, JR. DECEASED\n\n"
+ "SMITH, JOHN, P.R. OF THE ESTATE OF\n"
+ "SMITH, JOHN, J, P.R. OF THE ESTATE OF\n"
+ "SMTIH, JOHN, JAMES, P.R. OF THE ESTATE OF\n\n"
+ "SMITH, JOHN JAMES EST\n"
+ "EST OF JOHN SMITH\n"
+ "SMITH REAL ESTATE LLC\n"
+ "PRALINES";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}