$re = '/sku-(\d+)sku-\1/m';
$str = '<sku>V31L-CPFIJK-11077</sku>
<image1>https://testtest.pl/getled/sku-11077sku-11077.jpg</image1>
<image2>https://testtest.pl/getled/sku-11077sku-11077,1.jpg</image2>
<sku>V31L-CPFIJK-11033</sku>
<image1>https://testtest.pl/getled/sku-11033sku-11033.jpg</image1>
<image2>https://testtest.pl/getled/sku-11033sku-11033,1.jpg</image2>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;