using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^art(?:\r?\n(?!art-|\s*code:""XXX"").*)*\r?\n\s*code:""XXX""(?:\r?\n(?!art-).*)*\r?\nart-";
string input = @"begin
more text
art
id:213213
code:""XXX""
name:234
art-
art
id:543
name:72
code:""AAA""
art-
art
code:""XXX""
id:32
name:46
art-
art
code:""CCC""
id:8765
art-
art
id:876
code:""DDD""
art-
even more text
even more text
end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}