import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^art(?:\\r?\\n(?!art-|\\s*code:\"XXX\").*)*\\r?\\n\\s*code:\"XXX\"(?:\\r?\\n(?!art-).*)*\\r?\\nart-";
final String string = "begin\n"
+ "more text \n"
+ "art\n"
+ " id:213213\n"
+ " code:\"XXX\"\n"
+ " name:234\n"
+ "art-\n"
+ "art\n"
+ " id:543\n"
+ " name:72\n"
+ " code:\"AAA\"\n"
+ "art-\n"
+ "art\n"
+ " code:\"XXX\"\n"
+ " id:32\n"
+ " name:46\n"
+ "art-\n"
+ "art\n"
+ " code:\"CCC\"\n"
+ " id:8765\n"
+ "art-\n"
+ "art\n"
+ " id:876\n"
+ " code:\"DDD\"\n"
+ "art-\n"
+ "even more text\n"
+ "even more text\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}