$re = '/(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)/';
$str = 'sinh xyz';
$subst = "\1\2\3(\4)";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;