re = /(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)/
str = 'sinh xyz'
subst = '\\1\\2\\3(\\4)'
result = str.sub(re, subst)
# Print the result of the substitution
puts result