$re = '/([A-Z]|(?!\A)\G)(\d+z)/';
$str = 'A42z19z037z21zB942z21z4842zC33z449z3884z68z20z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);