import Foundation
let pattern = #"<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)