package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[.*?\]`)
var str = `[caption id="attachment_90" align="alignleft" width="400"] xxxxxxxxxxxxxxxxxxxx[/caption]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}