#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<suburb>(.+?)<\/suburb>"
Local $sString = " <primaryAddress>" & @CRLF & _
" <addressLine>280 Flinders Mall</addressLine>" & @CRLF & _
" <geoCodeGranularity>PROPERTY</geoCodeGranularity>" & @CRLF & _
" <latitude>-19.261365</latitude>" & @CRLF & _
" <longitude>146.815585</longitude>" & @CRLF & _
" <postcode>4810</postcode>" & @CRLF & _
" <state>QLD</state>" & @CRLF & _
" <suburb>Townsville</suburb>" & @CRLF & _
" <type>PHYSICAL</type>" & @CRLF & _
" </primaryAddress>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")