#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{1,3}(?:\.[0-9]{3})*,[0-9]{2}(?![0-9])"
Local $sString = "Valid" & @CRLF & _
"455,80SomeText" & @CRLF & _
"1,00" & @CRLF & _
"30,82" & @CRLF & _
"7,78 SomeText" & @CRLF & _
"622,21" & @CRLF & _
"8.542,85" & @CRLF & _
"" & @CRLF & _
"Invalid examples" & @CRLF & _
"455,482" & @CRLF & _
"54,1" & @CRLF & _
"7454,50" & @CRLF & _
",42"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")