# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9]{1,3}(?:\.[0-9]{3})*,[0-9]{2}(?![0-9])"
test_str = ("Valid\n"
"455,80SomeText\n"
"1,00\n"
"30,82\n"
"7,78 SomeText\n"
"622,21\n"
"8.542,85\n\n"
"Invalid examples\n"
"455,482\n"
"54,1\n"
"7454,50\n"
",42")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.