$re = '/^[^\[\]]*(?:\[[^\[\]]*\][^\[\]]*)*[^\[\]]*$/m';
$str = 'A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22;DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD[11;[3],2;33];EEEEE[1111]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);