using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\begin\{enumerate\})(?=\s\\end\{enumerate\}\s\s\\questao\{\d+\}$)";
string input = @"\questao{1}
\begin{enumerate}
\end{enumerate}
\begin{enumerate}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\questao{2}
\begin{enumerate}
\end{enumerate}
\questao{2}
\begin{enumerate}
fdafsafdsa
\end{enumerate}
\questao{2}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}