import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\begin\\{enumerate\\})(?=\\s\\\\end\\{enumerate\\}\\s\\s\\\\questao\\{\\d+\\}$)";
final String string = "\\questao{1}\n\n"
+ "\\begin{enumerate}\n"
+ "\\end{enumerate}\n\n"
+ "\\begin{enumerate}\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{2}\n\n"
+ "\\begin{enumerate}\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{2}\n\n"
+ "\\begin{enumerate}\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{2}\n\n"
+ "\\begin{enumerate}\n"
+ "fdafsafdsa\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}