re = /(\d+)x([^[]+)\[([^]]+)\]=\[([^]]+)\]/
str = '2xMUA Matte Lipstick - Totally Nude[300]=[600]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end