#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z]+)[\s\-\.]+(\d{1,2})[\s\-\,]+(\d{4})"
Local $sString = "04/20/2009; 04/20/09; 4/3/09 7/8/71" & @CRLF & _
"Mar-20-2009; Mar 20, 2009; March 20, 2009; Mar. 20, 2009; Mar 20 2009" & @CRLF & _
"20 Mar 2009; 20 March 2009; 20 Mar. 2009; 20 March, 2009" & @CRLF & _
"Mar 20th, 2009; Mar 21st, 2009; Mar 22nd, 2009" & @CRLF & _
"Feb 2009; Sep 2009; Oct 2010" & @CRLF & _
"6/2008; 12/2009" & @CRLF & _
"6/1998 Primary Care Doctor:" & @CRLF & _
"2009; 2010" & @CRLF & _
"(4/10/71)Score-1Audit C Score Current: 9/27/75. " & @CRLF & _
"1; 10/13/1976 Audit C Score," & @CRLF & _
"4-13-82 Other Child Mental occasion 5/21/77." & @CRLF & _
"1; 10/13/1976 Audit C" & @CRLF & _
"(1988-now)" & @CRLF & _
"B12 969 2007" & @CRLF & _
"Lab: B12 969 2007" & @CRLF & _
"Ely 708-810-7787 " & @CRLF & _
"February, 2010" & @CRLF & _
"URUGUAY September 1984." & @CRLF & _
"7HH, April 1985 Hx of Outpatient" & @CRLF & _
"Venlafaxine 37.5mg daily: May, 2011: self-discontinued" & @CRLF & _
") Paxil (Jan 1978) : sedation" & @CRLF & _
"LFTs WNL (October 1996)Problems Opioid dependence" & @CRLF & _
""I wasn't getting anywhere" (April 1988)Prior" & @CRLF & _
"Prozac 20 mg daily: February, 1995: self-discontinued" & @CRLF & _
"sLexapro (1988-now): Good response (anxiety)" & @CRLF & _
"pOct 2015 - Admitted to Gray" & @CRLF & _
"lNovember 1990 - NPCCHx of Outpatient Treatment: Yes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")