const regex = /\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0*1(?=0+~)|\\b0+|([0-9])(?=0*~[0-9]*?\\1([0-9]))|~[0-9]*', 'g')
const str = `000~09876543210
0001~09876543210
1~09876543210
2~09876543210
3~09876543210
004~09876543210
10~09876543210
0010~09876543210
0020~09876543210
210~09876543210
438~09876543210
1000~09876543210`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);