using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"stringBuilder\.append\(""(.)""\)";
string substitution = @"stringBuilder.append('$1')";
string input = @"stringBuilder.append(""x"")
sysout.println(""x"" + 2)
sysout.println('x' + 2)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}