re = /stringBuilder\.append\("(.)"\)/m
str = 'stringBuilder.append("x")
sysout.println("x" + 2)
sysout.println(\'x\' + 2)'
subst = 'stringBuilder.append(\'$1\')'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result