#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^.\n]+#([^#.\n]+)"
Local $sString = "sentence#newsletter.#hello" & @CRLF & _
"hello#music" & @CRLF & _
"#hello#music" & @CRLF & _
"hello.com#music"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)