use strict;
my $str = 'foobar9
foobar
fooba6
sh&gsgg
fo777777';
my $regex = qr/^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";