import Foundation
let pattern = #"^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foobar9
foobar
fooba6
sh&gsgg
fo777777
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)