package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="ftp:([^"]+)">`)
var str = `<a href="ftp://mysite.com"> some stuff </a>
<a href="ftp://mysite.com" class="foo"> some stuff </a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}