$re = '/<a href="ftp:([^"]+)">/';
$str = '<a href="ftp://mysite.com"> some stuff </a>
<a href="ftp://mysite.com" class="foo"> some stuff </a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);