# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}/B/gm;t' <<< "<a href=\"#\" title=\"Sample Fee – also see B11023\">G14015</a>"