#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}"
Local $sString = "<a href="#" title="Sample Fee – also see B11023">G14015</a>"
Local $sSubst = "B"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)