using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}";
string substitution = @"B";
string input = @"<a href=""#"" title=""Sample Fee – also see B11023"">G14015</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}