use strict;
my $str = '<a href="#" title="Sample Fee – also see B11023">G14015</a>';
my $regex = qr/(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}/mp;
my $subst = 'B';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";