$re = '/(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}/m';
$str = '<a href="#" title="Sample Fee – also see B11023">G14015</a>';
$subst = "B";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;