use strict;
my $str = '/* \'aa/\' */
/*!test*/
/* someone said \'hello\' */
/* "hello"*/
/***test****/
/******
\'test\'
****/
/****
test
****/
// let\'s try a single quote here "test"
/*
test
*/
/*\'test\'*/
/*
test
*/
/*
\'test \' */
/** @require \'aa/*\' */
.test
content \'\'/* test */
.test content "/* test */"
.test content /* test */
@require \'aaa/*\'
@require \'bbb/*\' /* test */
@require \'ccc/*\'
@require \'ccc/* ab */\' /* test */
@require \'ddd/*\' /*test \'*/
@require "ddd/*" /*test \'*/
@require \'eee/*\'
// test again
@require \'fff/*\'
@require \'ggg/*\'
@require \'hhh/*\'
@require \'iii/*\'
@require \'jjj/*\' /*
test */
@require \'kk/**/*\'';
my $regex = qr/(^(\/\*)|([ \t'"](\/\*)))(?!\/)(.|[\r\n]|\n)+?\*\/\n?\n?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}