$re = '/(^(\/\*)|([ \t\'"](\/\*)))(?!\/)(.|[\r\n]|\n)+?\*\/\n?\n?/m';
$str = '/* \'aa/\' */
/*!test*/
/* someone said \'hello\' */
/* "hello"*/
/***test****/
/******
\'test\'
****/
/****
test
****/
// let\'s try a single quote here "test"
/*
test
*/
/*\'test\'*/
/*
test
*/
/*
\'test \' */
/** @require \'aa/*\' */
.test
content \'\'/* test */
.test content "/* test */"
.test content /* test */
@require \'aaa/*\'
@require \'bbb/*\' /* test */
@require \'ccc/*\'
@require \'ccc/* ab */\' /* test */
@require \'ddd/*\' /*test \'*/
@require "ddd/*" /*test \'*/
@require \'eee/*\'
// test again
@require \'fff/*\'
@require \'ggg/*\'
@require \'hhh/*\'
@require \'iii/*\'
@require \'jjj/*\' /*
test */
@require \'kk/**/*\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);