$re = '/^\d{1,14}$ |
^\d{3}-\d{1,3}$ |
^\d{3}-\d{1,3}-\d{1,4}$ |
^\d{3}-\d{1,3}-\d{1,4}\s\d{1,4}$/mx';
$str = '333
333-3
333-333-3333
333-333-3333 3333
33333333333333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);