$re = '/ad</div>((?!<div>).)*<div>(((?!<\/div>).)*)</div>/s';
$str = '""" <div>ad</div> \\n\\n <div> correct
value </div> <div> wrong value </div> """';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);