import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\w[^\\W]+)[\\.\\-]?){1,}\\@(([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$";
final String string = "JOAO!DA.SILVA@CNN,COM (INVALID)\n"
+ "joao@microsoft.com\n"
+ "mauricio.teste@site.ba.gov.br\n"
+ "santana.teste@sistema-ba.ba.gov.br\n"
+ "teste.teste.teste.igor.caza@google.com\n"
+ "teste.teste.teste.igor.caza@globo.com.br\n"
+ "ayslan-johnson@teste.com.br\n"
+ "joao@123.com\n"
+ "ayslanjohnson@google.com\n"
+ "teste.teste.teste.igor.caza@globo (INVALID)\n"
+ "SILVA.teste@SITE-ba.ba.gov.br. (INVALID)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}