import Foundation
let pattern = #"(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1234 Alpha Bee"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)