package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\/feed`)
var str = `https://$url/$uri/feed`
var substitution = "\1\/"
fmt.Println(re.ReplaceAllString(str, substitution))
}