use strict;
my $str = '2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357';
my $regex = qr/\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";