// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}").unwrap();
let string = "2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}