#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(I like to find )(.*?)( in )([^.]*)(\.)(.*)"
Local $sString = "I like to find something vicous in somewhere bla bla bla." & @CRLF & _
"https://address.suffix.com/level/somelongurlstuff"
Local $sSubst = "$4 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)