package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(I like to find )(.*?)( in )([^.]*)(\.)(.*)`)
var str = []byte(`I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff`)
var substitution = []byte("$4 $2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}