$re = '/#\[\[(?<name>.+?)\]\]/';
$str = 'my first tag is #[[1:hashTag:Rameez]] and second tag is #[[2:hashTag:Rameez2]].
Did I forget to mention that last tag is #[[3:hashTag:Rameez2]]?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);