using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!!!\s*([^?]+?)\s*\?{3}";
string input = @"Image 56 ::: Beach, Summer, Sun !!! John Smith ???
Image 57 ::: Beach, Summer, Sun !!!Jane Doe???
Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}